La migration de Drupal 5 à Drupal 6 : Différence entre versions

De April MediaWiki
(Ajout du module Alexendrie)
(Ajout de notes sur les mises à jour + mise à jours de n° de version des modules à mettre à jour)
Ligne 11 : Ligne 11 :
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"
 
|-
 
|-
! Module || Version || Commentaire || Utile
+
! Module || Version || Commentaire || Utile || Notes sur la mise à jour
 
|-
 
|-
| admin_menu || 6.x-1.5 ||/ ||bgcolor="#a0ffa0"| Purement gadget
+
| admin_menu || 6.x-1.5 ||/ ||bgcolor="#a0ffa0"| Purement gadget, pas activé
 
|-
 
|-
 
| alexandrie ||Module interne April || A vérifier si le module fonctionne sous Drupal 6  ||bgcolor="#a0ffa0"| Utile, peut être temporairement désactivé
 
| alexandrie ||Module interne April || A vérifier si le module fonctionne sous Drupal 6  ||bgcolor="#a0ffa0"| Utile, peut être temporairement désactivé
Ligne 19 : Ligne 19 :
 
| advcontact || 6.x-1.1 || / ||bgcolor="#a0ffa0"| Oui
 
| advcontact || 6.x-1.1 || / ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
| affiliates || 6.x-1.8 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à supprimer.
+
| affiliates || 6.x-1.10 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à supprimer.
 
|-
 
|-
| alinks || 6.x-1.0-rc1 || ||bgcolor="#a0ffa0"| Oui
+
| alinks || 6.x-1.0-rc1 || ||bgcolor="#a0ffa0"| Oui || La dernière release pour D6 date de 15 otc. 2008 et est une RC
 
|-
 
|-
| cck || 6.x-2.5 || / ||bgcolor="#a0ffa0"| Oui
+
| cck || 6.x-2.6 || / ||bgcolor="#a0ffa0"| Oui || Il faut d'abord mettre à jour les modules en dépendant en version 5.x cf. http://drupal.org/project/cc
 
|-
 
|-
| contact_forms || 6.x-1.5 || / ||bgcolor="#a0ffa0"| Sans doute utilisé comme advcontact
+
| contact_forms || 6.x-1.12 || / ||bgcolor="#a0ffa0"| Sans doute utilisé comme advcontact
 
|-
 
|-
 
| contemplate || 6.x-1.1 || / ||bgcolor="#a0ffa0"| oui, par snip
 
| contemplate || 6.x-1.1 || / ||bgcolor="#a0ffa0"| oui, par snip
 
|-
 
|-
| date || 6.x-2.3 || / ||bgcolor="#a0ffa0"| il serait utile de s'en servir avec CCK pour des champs de date, mais il y a un bug avec la présence event.
+
| date || 6.x-2.4 || / ||bgcolor="#a0ffa0"| il serait utile de s'en servir avec CCK pour des champs de date, mais il y a un bug avec la présence event.
 
|-
 
|-
| diff || 6.x-2.1-alpha2 || ||bgcolor="#a0ffa0"| Oui
+
| diff || 6.x-2.0 || ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
 
| docs || ? || Pas de version 6.x ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
| docs || ? || Pas de version 6.x ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
Ligne 37 : Ligne 37 :
 
| downld || ? || Pas de version 6.x; Contournement dans les correctifs ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
| downld || ? || Pas de version 6.x; Contournement dans les correctifs ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
|-
 
|-
| event || 6.x-2.x-dev || Development snapshot ||bgcolor="#a0ffa0"| Oui à priori, mais va être supprimer pour une autre solution de gestion des événement.
+
| event || 6.x-2.x-dev || Development snapshot ||bgcolor="#a0ffa0"| Oui à priori, mais va être supprimer pour une autre solution de gestion des événement. || Possibilité d'export en iCal pour un migration vers Date+Calendar après migration en D6. cf http://drupal.org/node/524394
 
|-
 
|-
 
| event_manager || ? || Pas de version 6.x; Peut être remplacé par Event + Signup + Calendar + Signup Scheduler ||bgcolor="#a0ffa0"| Va être supprimer comme event.
 
| event_manager || ? || Pas de version 6.x; Peut être remplacé par Event + Signup + Calendar + Signup Scheduler ||bgcolor="#a0ffa0"| Va être supprimer comme event.
 
|-
 
|-
| footnotes || 6.x-2.1 || / ||bgcolor="#a0ffa0"| Oui
+
| footnotes || 6.x-2.3 || / ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
 
| gdtc || Module interne April || A vérifier si le module fonctionne sous Drupal 6 ||bgcolor="#a0ffa0"| Oui
 
| gdtc || Module interne April || A vérifier si le module fonctionne sous Drupal 6 ||bgcolor="#a0ffa0"| Oui
Ligne 47 : Ligne 47 :
 
| gdtc_auth || Module interne April || A vérifier si le module fonctionne sous Drupal 6 ||bgcolor="#a0ffa0"| Oui
 
| gdtc_auth || Module interne April || A vérifier si le module fonctionne sous Drupal 6 ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
| i18n || 6.x-1.1 || / ||bgcolor="#a0ffa0"| Oui
+
| i18n || 6.x-1.4 || / ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
 
| importexportapi || 6.x-1.x-dev || Development snapshot ||bgcolor="#a0ffa0"| Utilisés lors de la migration. Peut être supprimé
 
| importexportapi || 6.x-1.x-dev || Development snapshot ||bgcolor="#a0ffa0"| Utilisés lors de la migration. Peut être supprimé
 
|-
 
|-
| insert_view || 6.x-1.0 || / ||bgcolor="#a0ffa0"| Oui, pour insérer le contenu d'une view dans un node.
+
| insert_view || 6.x-2.x-dev || / ||bgcolor="#a0ffa0"| Oui, pour insérer le contenu d'une view dans un node. || Déconseillé suite à des problème de sécurité, cf. http://drupal.org/project/insert_view
 
|-
 
|-
| link || 6.x-2.6 || / ||bgcolor="#a0ffa0"| Oui, sous-module de CCK.
+
| link || 6.x-2.8 || / ||bgcolor="#a0ffa0"| Oui, sous-module de CCK.
 
|-
 
|-
 
| liquid || ? || Pas de version 6.x || bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
| liquid || ? || Pas de version 6.x || bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
Ligne 59 : Ligne 59 :
 
| media_mover || 6.x-1.0-beta2 || / ||bgcolor="#a0ffa0"| A supprimer.
 
| media_mover || 6.x-1.0-beta2 || / ||bgcolor="#a0ffa0"| A supprimer.
 
|-
 
|-
| mimemail || 6.x-1.x-dev || Development snapshot || bgcolor="#a0ffa0"| A garder, sans doute utilier pour des mails en HTML par des modules tel que contact ou tell a friend.
+
| mimemail || 6.x-1.0-alpha2 || Development snapshot || bgcolor="#a0ffa0"| A garder, sans doute utilier pour des mails en HTML par des modules tel que contact ou tell a friend.
 
|-
 
|-
 
| node_clone || 6.x-1.0 || / ||bgcolor="#a0ffa0"| <s>Oui, pas fondamental mais est utile</s> J'ai cru comprendre que son fonctionnement avec i18n n'est pas recommendé. A supprimer donc.
 
| node_clone || 6.x-1.0 || / ||bgcolor="#a0ffa0"| <s>Oui, pas fondamental mais est utile</s> J'ai cru comprendre que son fonctionnement avec i18n n'est pas recommendé. A supprimer donc.
Ligne 74 : Ligne 74 :
 
| og || 6.x-2.0 || / ||bgcolor="#a0ffa0"| à supprimer et trouver une solution correcte pour gérer les permissions (des groupes de travail).
 
| og || 6.x-2.0 || / ||bgcolor="#a0ffa0"| à supprimer et trouver une solution correcte pour gérer les permissions (des groupes de travail).
 
|-
 
|-
| panels || 6.x-3.0 ||/ ||bgcolor="#a0ffa0"| Oui
+
| panels || 6.x-3.3 ||/ ||bgcolor="#a0ffa0"| Oui || cf. http://drupal.org/node/515140 pour les notes sur une mise à jour du Panels 2 vers Panels 3
 
|-
 
|-
| pathauto || 6.x-1.1 ||/ ||bgcolor="#a0ffa0"| Oui
+
| pathauto || 6.x-1.3 ||/ ||bgcolor="#a0ffa0"| Oui || Après mise à jour, il est nécessaire de vérifier la configuration. cf INSTALL.txt
 
|-
 
|-
| path_redirect || 6.x-1.0-beta4 || / ||bgcolor="#a0ffa0"| Pas utilisé, bye ;).
+
| path_redirect || 6.x-1.0-beta6 || / ||bgcolor="#a0ffa0"| Pas utilisé, bye ;).
 
|-
 
|-
| print || 6.x-1.8 || / ||bgcolor="#a0ffa0"| Oui
+
| print || 6.x-1.10 || / ||bgcolor="#a0ffa0"| Oui || Requiert Drupal 6.11+
 
|-
 
|-
 
| private_upload || 6.x-1.0-rc2 || / ||bgcolor="#a0ffa0"| Test pour le chargement des fichiers. Peut être supprimé
 
| private_upload || 6.x-1.0-rc2 || / ||bgcolor="#a0ffa0"| Test pour le chargement des fichiers. Peut être supprimé
 
|-
 
|-
| quotes || 6.x-1.30 || / ||bgcolor="#a0ffa0"| Oui
+
| quotes || 6.x-1.40 || / ||bgcolor="#a0ffa0"| Oui
 
|-
 
|-
| search404 || 6.x-1.7 || Ne sera peut-être pas utile avec D6 ||bgcolor="#a0ffa0"| Oui, mais n'est pas la solution parfaite. http://www.april.org/wws/arc/siteweb/2008-12/msg00016.html Il ajoute un formualire de recherche car la recherche a partir d'une page 404 ne fonctionne pas.
+
| search404 || 6.x-1.9 || Ne sera peut-être pas utile avec D6 ||bgcolor="#a0ffa0"| Oui, mais n'est pas la solution parfaite. http://www.april.org/wws/arc/siteweb/2008-12/msg00016.html Il ajoute un formualire de recherche car la recherche a partir d'une page 404 ne fonctionne pas.
 
|-
 
|-
 
| service_links || 6.x-1.0 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à supprimer.
 
| service_links || 6.x-1.0 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à supprimer.
Ligne 92 : Ligne 92 :
 
| simplenews || 6.x-1.0-rc6 || / ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
| simplenews || 6.x-1.0-rc6 || / ||bgcolor="#a0ffa0"| ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
 
|-
 
|-
| syndication || 6.x-1.5 || / ||bgcolor="#a0ffa0"| Semble répondre à un problème. A bien regarder pour voir comment l'utiliser.
+
| syndication || 6.x-1.6 || / ||bgcolor="#a0ffa0"| Semble répondre à un problème. A bien regarder pour voir comment l'utiliser.
 
|-
 
|-
| tableofcontents || 6.x-3.1 || / ||bgcolor="#a0ffa0"| oui
+
| tableofcontents || 6.x-3.5 || / ||bgcolor="#a0ffa0"| oui
 
|-
 
|-
 
| tagadelic || 6.x-1.2 || / ||bgcolor="#a0ffa0"| Oui, mais pas forcement nécessaire.
 
| tagadelic || 6.x-1.2 || / ||bgcolor="#a0ffa0"| Oui, mais pas forcement nécessaire.
 
|-
 
|-
| taxonomy_batch_operations || ? || Pas de version 6.x; Peut être remplacé par VBO ||bgcolor="#a0ffa0"| A supprimer, sans doute utiliser lors de la migration. Utile uniquement pour des administrateurs.
+
| taxonomy_batch_operations || ? || Pas de version 6.x; Peut être remplacé par VBO (http://drupal.org/project/views_bulk_operations) ||bgcolor="#a0ffa0"| A supprimer, sans doute utiliser lors de la migration. Utile uniquement pour des administrateurs.
 
|-
 
|-
 
| tellafriend || 6.x-2.8 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à garder pour le plaisir d'alxc.
 
| tellafriend || 6.x-2.8 || / ||bgcolor="#a0ffa0"| Est dans la catégorie "module inutile de démocratisation", à garder pour le plaisir d'alxc.
Ligne 108 : Ligne 108 :
 
| uploadpath || 6.x-1.0 || / ||bgcolor="#a0ffa0"| semble répondre au problème soulevé par le grand bazar du dossier files mais, paradoxalement ne semble pas avoir été utilisé jusqu'au bout. Peut être désactiver, à mettre en place pour la D6.
 
| uploadpath || 6.x-1.0 || / ||bgcolor="#a0ffa0"| semble répondre au problème soulevé par le grand bazar du dossier files mais, paradoxalement ne semble pas avoir été utilisé jusqu'au bout. Peut être désactiver, à mettre en place pour la D6.
 
|-
 
|-
| views || 6.x-2.6 || / ||bgcolor="#a0ffa0"| Oui
+
| views || 6.x-2.6 || / ||bgcolor="#a0ffa0"| Oui || Conversion manuelle de chaque view nécessaire après la mise à jour.
 
|-
 
|-
 
| view_unpublished || / || Pas de version 6.x; Correctif dans les contributions ||bgcolor="#a0ffa0"| Oui
 
| view_unpublished || / || Pas de version 6.x; Correctif dans les contributions ||bgcolor="#a0ffa0"| Oui
Ligne 114 : Ligne 114 :
 
| webform || 6.x-2.7 || / ||bgcolor="#a0ffa0"| Ne semble pas être utilisé puise ce module ajoute un type de contenu et aucun node de type webform n'existe. A supprimer.
 
| webform || 6.x-2.7 || / ||bgcolor="#a0ffa0"| Ne semble pas être utilisé puise ce module ajoute un type de contenu et aucun node de type webform n'existe. A supprimer.
 
|-
 
|-
| xmlsitemap || 6.x-1.0-rc2 || / ||bgcolor="#a0ffa0"| ???  peut-être utile pour voir la liste des pages. pourquoi pas ??? Est utile pour le référencement. A GARDER (snip)
+
| xmlsitemap || 6.x-1.2 || / ||bgcolor="#a0ffa0"| ???  peut-être utile pour voir la liste des pages. pourquoi pas ??? Est utile pour le référencement. A GARDER (snip) || cf. INSTALL.txt pous instructions de mise à jour
 
|-
 
|-
 
|}
 
|}
Ligne 239 : Ligne 239 :
 
** Views
 
** Views
 
** Panels
 
** Panels
 +
----
 +
Concernant node_clone et i18n. Après lecture rapide de http://drupal.org/node/365797, il semblerait que les problèmes soient présent en D6 et '''D5'''. A tester donc. Si après test, des conflits avec i18n sont confirmés, selon le(s) cas d'utilisation, il est probablement possible de créer un module ad-hoc pour cloner de node d'un ou des types de contenus particulier.--[[Utilisateur:Pbuyle|Pierre Buyle]] 3 mai 2010 à 15:22 (CEST)

Version du 3 mai 2010 à 14:22

Logo-drupal.png Bienvenue sur une page Logo-drupal.png
du groupe de travail Site Web

Cette page est actuellement (mai 2009) utilisée pour le travail sur le site Web. Elle fait partie d'un projet plus vaste : la mise en place d'une seconde version pour le site Web sous Drupal.

Liste des modules Drupal utilisés

Liste des modules Drupal 5 utilisés sur le site et les équivalents sous Drupal 6 :

Module Version Commentaire Utile Notes sur la mise à jour
admin_menu 6.x-1.5 / Purement gadget, pas activé
alexandrie Module interne April A vérifier si le module fonctionne sous Drupal 6 Utile, peut être temporairement désactivé
advcontact 6.x-1.1 / Oui
affiliates 6.x-1.10 / Est dans la catégorie "module inutile de démocratisation", à supprimer.
alinks 6.x-1.0-rc1 Oui La dernière release pour D6 date de 15 otc. 2008 et est une RC
cck 6.x-2.6 / Oui Il faut d'abord mettre à jour les modules en dépendant en version 5.x cf. http://drupal.org/project/cc
contact_forms 6.x-1.12 / Sans doute utilisé comme advcontact
contemplate 6.x-1.1 / oui, par snip
date 6.x-2.4 / il serait utile de s'en servir avec CCK pour des champs de date, mais il y a un bug avec la présence event.
diff 6.x-2.0 Oui
docs ? Pas de version 6.x ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
downld ? Pas de version 6.x; Contournement dans les correctifs ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
event 6.x-2.x-dev Development snapshot Oui à priori, mais va être supprimer pour une autre solution de gestion des événement. Possibilité d'export en iCal pour un migration vers Date+Calendar après migration en D6. cf http://drupal.org/node/524394
event_manager ? Pas de version 6.x; Peut être remplacé par Event + Signup + Calendar + Signup Scheduler Va être supprimer comme event.
footnotes 6.x-2.3 / Oui
gdtc Module interne April A vérifier si le module fonctionne sous Drupal 6 Oui
gdtc_auth Module interne April A vérifier si le module fonctionne sous Drupal 6 Oui
i18n 6.x-1.4 / Oui
importexportapi 6.x-1.x-dev Development snapshot Utilisés lors de la migration. Peut être supprimé
insert_view 6.x-2.x-dev / Oui, pour insérer le contenu d'une view dans un node. Déconseillé suite à des problème de sécurité, cf. http://drupal.org/project/insert_view
link 6.x-2.8 / Oui, sous-module de CCK.
liquid ? Pas de version 6.x ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
media_mover 6.x-1.0-beta2 / A supprimer.
mimemail 6.x-1.0-alpha2 Development snapshot A garder, sans doute utilier pour des mails en HTML par des modules tel que contact ou tell a friend.
node_clone 6.x-1.0 / Oui, pas fondamental mais est utile J'ai cru comprendre que son fonctionnement avec i18n n'est pas recommendé. A supprimer donc.
node_import 6.x-1.0-rc4 / Utilisés lors de la migration. Peut être supprimé
nodeteaser Pas de version 6.x; Nouvelle version dans les contributions Inutile avec Drupal 6 ? Je pense, mais si une fonction est utile, voir : http://drupalmodules.com/module-finder?title=teaser&v=6.x

à supprimer lors de la migration et VÉRIFIER que tout vas bien pour les teasers.

nodewords 6.x-1.0 / HORREUR ! Ajoute la premiere ligne (pas forcément une phrase complete) dans les entets HTML... A SUPPRIMER.
noreqnewpass 6.x-2.0 / Oui, dépendence de gdtc_auth
og 6.x-2.0 / à supprimer et trouver une solution correcte pour gérer les permissions (des groupes de travail).
panels 6.x-3.3 / Oui cf. http://drupal.org/node/515140 pour les notes sur une mise à jour du Panels 2 vers Panels 3
pathauto 6.x-1.3 / Oui Après mise à jour, il est nécessaire de vérifier la configuration. cf INSTALL.txt
path_redirect 6.x-1.0-beta6 / Pas utilisé, bye ;).
print 6.x-1.10 / Oui Requiert Drupal 6.11+
private_upload 6.x-1.0-rc2 / Test pour le chargement des fichiers. Peut être supprimé
quotes 6.x-1.40 / Oui
search404 6.x-1.9 Ne sera peut-être pas utile avec D6 Oui, mais n'est pas la solution parfaite. http://www.april.org/wws/arc/siteweb/2008-12/msg00016.html Il ajoute un formualire de recherche car la recherche a partir d'une page 404 ne fonctionne pas.
service_links 6.x-1.0 / Est dans la catégorie "module inutile de démocratisation", à supprimer.
simplenews 6.x-1.0-rc6 / ? n'est pas activé, n'est donc pas utilisé, est donc à supprimer.
syndication 6.x-1.6 / Semble répondre à un problème. A bien regarder pour voir comment l'utiliser.
tableofcontents 6.x-3.5 / oui
tagadelic 6.x-1.2 / Oui, mais pas forcement nécessaire.
taxonomy_batch_operations ? Pas de version 6.x; Peut être remplacé par VBO (http://drupal.org/project/views_bulk_operations) A supprimer, sans doute utiliser lors de la migration. Utile uniquement pour des administrateurs.
tellafriend 6.x-2.8 / Est dans la catégorie "module inutile de démocratisation", à garder pour le plaisir d'alxc.
themesettingsapi 6.x-1.4 / sans doute utilisé pour le thème personalisé. A garder.
token 6.x-1.12 / oui, pour des questions de dépendances
uploadpath 6.x-1.0 / semble répondre au problème soulevé par le grand bazar du dossier files mais, paradoxalement ne semble pas avoir été utilisé jusqu'au bout. Peut être désactiver, à mettre en place pour la D6.
views 6.x-2.6 / Oui Conversion manuelle de chaque view nécessaire après la mise à jour.
view_unpublished / Pas de version 6.x; Correctif dans les contributions Oui
webform 6.x-2.7 / Ne semble pas être utilisé puise ce module ajoute un type de contenu et aucun node de type webform n'existe. A supprimer.
xmlsitemap 6.x-1.2 / ??? peut-être utile pour voir la liste des pages. pourquoi pas ??? Est utile pour le référencement. A GARDER (snip) cf. INSTALL.txt pous instructions de mise à jour

Ce qu'on fait des modules

À désactiver, désinstaller et supprimer

À supprimer lors du nettoyage.

Sans scrupule

  • docs
  • downld
  • importexportapi
  • liquid
  • media_mover
  • node_import
  • nodewords
  • path_redirect
  • private_upload
  • simplenews
  • taxonomy_batch_operations

Un mot à dire

  • affiliates : s'en souvenir pour une éventuelle future utilisation (MI2D).
  • service_links : s'en souvenir pour une éventuelle future utilisation (MI2D).
  • webform : s'en souvenir pour une éventuelle future utilisation.

Entre les deux

A trouver une solution de remplacement

À [ supprimer / garder / mieux configurer / tester ] et trouver la solution de préférence lors de la migration

  • event : trouver une autre solution pour gérer les événements.
  • event_manager : trouver une autre solution pour gérer les événements.
  • og : trouver une autre solution pour gérer les permissions.
  • view_unpublished : trouver une autre solution pour gérer les permissions.
  • nodeteaser : il est sans doute inutile pour D6. Il faut vérifier qu'il n'y a pas de problèmes pour les teasers (http://drupalmodules.com/module-finder?title=teaser&v=6.x).
  • search404 : bien utile, mais n'est pas la solution parfaite. http://www.april.org/wws/arc/siteweb/2008-12/msg00016.html Il ajoute un formulaire de recherche car la recherche a partir d'une page 404 ne fonctionne pas.
  • node_clone : il est est indiqué qu'il y a des risque lors d'une utilisation avec i18n. Si nécessaire, à vérifier (sinon faire copier/coller).

À configurer pour bien les utiliser

  • alinks
  • date
  • syndication
  • uploadpath

Modules internes, à faire migrer

  • alexendrie
  • gdtc
  • gdtc_auth


À garder

Les fondamentaux

  • cck
  • i18n
  • panels
  • pathauto
  • views

Dépendances

  • noreqnewpass (de gdtc_auth)
  • token (de pathauto et peut-être de d'autres modules)

Pas fondamental mais utile

À supprimer s'ils posent problème.

  • admin_menu
  • contemplate
  • tagadelic
  • tellafriend
  • xmlsitemap

L'édition

  • diff
  • footnotes
  • print
  • tableofcontents

Utile / sous-module / Autre

  • advcontact
  • contact_forms
  • insert_view
  • link
  • mimemail
  • quotes
  • themesettingsapi

Modules potentiellement intéressants

  • workflow
  • devel
  • taxonomy_access
  • node_access
  • taxonomy_hide


Sous-modules de CCK

  • date
  • link
  • autocomplete_widgets / cck_autocomplete
  • computed_field
  • email
  • adressess
  • phone
  • filefield
  • imagefield
  • Node Reference du CCK, ou Node Insert (pour insérer un node dans un autre) LAL

Notes

  • SVN ou GIT : SVN installé
  • Installer Drush
  • [en cours]: Mettre en place D5 propre pour les tests
  • Rendre un peu plus propre la version de production (enlever des modules, modifier l'emplacement des modules)
  • Voir l'avancée de gDTCv2 : DTCv2
  • Comment régler la disparition du module teaser notamment pour les vidéos : http://www.april.org/fr/videos

---

  • Changement des types de contenus et taxo qui vont avec :
    • Backup BDD
    • Mettre le site en maintenance
    • Créer les nouveaux types de contenus, les configurer
    • Créer les nouveaux taxo, les configurer
    • Modification
    • Vérifier les permissions
    • Vérifier les views : SiteWeb:Liste des views
    • Tagadelic
  • Tente une migration, problèmes :
    • Thèmes
    • gDTC
    • Views
    • Panels

Concernant node_clone et i18n. Après lecture rapide de http://drupal.org/node/365797, il semblerait que les problèmes soient présent en D6 et D5. A tester donc. Si après test, des conflits avec i18n sont confirmés, selon le(s) cas d'utilisation, il est probablement possible de créer un module ad-hoc pour cloner de node d'un ou des types de contenus particulier.--Pierre Buyle 3 mai 2010 à 15:22 (CEST)